Pour pouvoir importer des images sur le serveur et consulter le wiki sans publicité, vous devez vous connecter.

Discussion modèle:Infobox Lieu

Guild Wars Wiki en français
Aller à : navigation, rechercher

TODO[modifier]

  • Fixer la largeur de l'infobox et en particulier celle des images : il faut d'abord remplacer les vignettes de tous les avant-postes et villes... car elles ne sont pas en pleine largeur et seront déformées. L'idéal reste la taille 340×255 pour les vignettes.
  • Gérer les guildes qui possède un avant-poste particulier (Factions) ?
  • Modifier le comportement du champ "nbr_screen" (comme dans l'infobox compétence) et le renommer en "image" pour uniformiser les infoboxes.

Proposition[modifier]

Inclure directement les screens avec une option "| screen = 6" afficherai 6 cases avec les mêmes dimensions que celle des galeries, S'inspirer peut être du modèle sur l'officiel. - Ouroboros (Discuter) 11 août 2008 à 03:38 (CEST)

Ca ferait une infobox vachement longue non ? Ca empêche pas qu'il faut que je modifie toutes les vignettes qui sont en 256×256.

Slideshow[modifier]

Je viens de tester (en preview, voyez aussi Campement de Gunnar) et c'est super !! - Icone Ratchet Ranger.png Ratchet Ranger 6 février 2008 à 20:08 (CET)

Normalement je vais l'intégrer de base dans le modèle actuel, j'attends de faire 2-3 test avant :] - Ouroboros (Discuter) 6 février 2008 à 20:11 (CET)

Images[modifier]

Là il y a un pitit problème, ce n'est plus une galerie d'images qui est affiché mais une colonne inintérompue d'images (voir Marais de la Pierre de Sang) sur IE (sinon sur Firefox c'est super ;)). - Boungawa Boungawa.png 2 septembre 2008 à 22:49 (CEST)

Tu as vider ton cache ? peut-être que ce n'est pas le bon fichier qui est en cache. C'est sur IE7 ou IE6? - Ouroboros (Discuter) 2 septembre 2008 à 22:57 (CEST)
Hihihi IE fait totalement n'importe quoi ^^ sous Firefox, Opera et Google Chrome aucun problème. - Lautrig Lautrig(discuter) 2 septembre 2008 à 22:58 (CEST)
Effectivement sous IE ça foire... je cherche une solution. - Ouroboros (Discuter) 2 septembre 2008 à 22:59 (CEST)
Sinon je trouve ça sympa au premier abord, mais peut être fatiguant pour les yeux de pas avoir quelque chose de fixe. Les images seront à contrôler parce que pas mal de trop grandes qui cachent une partie de l'infobox et d'autres trop petites qui laissent une zone blanche pour respecter le 255px. - Lautrig Lautrig(discuter) 2 septembre 2008 à 23:01 (CEST)
Ca sanctionne le fait que les directives ne sont pas toujours respectées lol (elles sont pas là pour rien, généralement c'est parce qu'à un instant "t" j'ai une idée de ce que je vais faire 6 mois après ^^). Enfin bon c'est pas gravissime, ça peut se corriger.
C'est quoi "vider son cache" ? - Boungawa Boungawa.png 2 septembre 2008 à 23:04 (CEST)
Un petit Ctrl+F5 pour actualiser la page en vidant le cache. - Lautrig Lautrig(discuter) 2 septembre 2008 à 23:07 (CEST)
Ah oui ça j'ai fait. - Boungawa Boungawa.png 2 septembre 2008 à 23:09 (CEST)
Bon là je vais voir mon copain (ouais c'est vachement l'heure ^^) et je regarde ça après, car en fait c'est pas simple à débugger (faut que je trouve un débugger JS, car l'erreur d'IE n'est pas très causante). En tout cas ça bloque la majorité des javascripts, donc sapuducul ^^. Faut que je corrige le tir rapidement, enfin avant demain. - Ouroboros (Discuter) 2 septembre 2008 à 23:34 (CEST)
J'arrive pas à trouver, je vais voir entre midi et deux. - Ouroboros (Discuter) 3 septembre 2008 à 08:24 (CEST)
Là ça le fait aussi sur firefox maintenant - Boungawa Boungawa.png 3 septembre 2008 à 15:37 (CEST)
J'ai viré le script pendant quelques heures, au moins ça permet aux palettes de navigation de marcher correctement pendant que je cherche une solution au problème. - Ouroboros (Discuter) 3 septembre 2008 à 17:33 (CEST)
Ok c'est corrigé, IE et Firefox sont supportés (les autres je sais pas, en même temps osef). Je viens en plus d'apprendre un truc fort utile sur IE/JS. - Ouroboros (Discuter) 4 septembre 2008 à 21:04 (CEST)
Ça fonctionne sous Opera et Chrome. Sur tous les navigateurs presque on se rend compte qu'au chargement, ça place toutes les images les unes sous les autres, puis une fois la page finie de charger, tout se passe comme prévu (le chargement dure entre 0 et 1/2 seconde donc c'est pas vraiment visible ^^). - Lautrig Lautrig(discuter) 5 septembre 2008 à 00:18 (CEST)
IE 5 et 6 donnent une erreur de script, et si on continue, les images sont les unes sous les autres. IE 7 pas de problème. IE 8 beta 1, ça défile bien, mais il y a une grande zone blanche sous l'image, correspondant à l'espace qu'occuperaient les 6 autres images si elles étaient affichées les unes sous les autres (comme dans IE 5 et 6). Je donne juste ce que IETester m'affiche et perso je m'en contrefiche des versions IE autres que la 7. - Lautrig Lautrig(discuter) 5 septembre 2008 à 00:18 (CEST)
Ah dommage pour IE8, j'y regarderais quand même cette nuit ou lundi (ce week-end il est possible que je ne sois pas dispo). Pour le problème des images les unes au dessous des autres, c'est normal.
J'ai remarqué néanmoins un bug avec Firefox et IE7, c'est que les images dépassent légèrement du cadre... je suis actuellement en train de débugger ça (entre autre). - Ouroboros (Discuter) 5 septembre 2008 à 00:30 (CEST)
Par contre y'a une petite erreur de décalage avec le cadre :Décalage.bmp
C'est de ça dont je parle dans mon message précèdent. - Ouroboros (Discuter) 5 septembre 2008 à 13:03 (CEST)
ah oui excuse moi^^ :S :P... - Boungawa Boungawa.png 5 septembre 2008 à 13:07 (CEST)
Il reste encore un problème d'ajustement que je vais corriger dès que possible (image pas assez large maintenant lol). Il faut que je nettoie le code HTML de toute façon. - Ouroboros (Discuter) 5 septembre 2008 à 13:57 (CEST)